
v7.3 Release Notes for Websense 
Email Security
Topic 40000 / Updated: 10-Nov-2010

Applies To:

Websense Email Security version 7.3 is a feature release offering considerable 
enhancements and improvements to usability, security, and file protection. It also 
contains some tips for configuring new features of Websense Email Security.

Websense Email Security version 7.3 is released with Personal Email Manager 
version 7.3 and Report Central version 7.3. The Personal Email Manager component 
includes some new features and enhancements. Report Central contains no new 
features.

Key features in this release
Topic 40001 / Updated: 10-Nov-2010

Applies To:

Key features in this release include support for several systems including Microsoft 
2008 R2 Active Directory, Microsoft Small Business Server 2008, Microsoft SQL 
Server 2008 Express, Microsoft Exchange Server 2010, Microsoft Windows 7, and 
VMWare technology. Other enhancements include integration to the Directory Server, 
simplified and efficient data management, and improved file protection.

Improved proxy support during installation

You can configure the proxy settings to the download server and update server  
through the user interface rather than through the registry. This feature improves the 
usability of the product and makes it easier for you to define or update proxy 
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information. The username and password are also encrypted in the registry to ensure 
your local machine is protected and secure.

If authentication isn't required, you can leave the username 
and password blank.

Edit the proxy information in the Configuration Wizard when you do a new 
installation of Websense Email Security, or open Websense Email Security and select 
Tools > Options.

Customizable footer and banner

You can customize the footer and banner by adding an image or HTML. HTML and 
JPG are newly supported in Websense Email Security v7.3.

You can also use the Directory Server look-up function to insert your personal details 
(such as phone number, fax number, position title) directly into the footer and banner. 
This feature reduces the need to manually update the footer whenever your personal 
detail in the Directory Server is changed.

Better protection against adult content in image files 

Websense Email Security v7.3 uses the latest image filter library file. The Virtual 
Image Agent has also been upgraded to provide greater protection in detecting 
inappropriate images within messages. 

Virtual Image Agent is a separate licensed component. 
Contact your local sale representative for information on 
how to subscribe to this component.

 Support for email addresses with BATV format

Some emails added to the whitelist or the blacklist in Personal Email Manager were 
blocked by Websense Email Security. Those emails were incorrectly blocked because 
they had Bounce Address Tag Validation (BATV) turned on. Emails with BATV 
turned on can be identified by the prvs= tag string added to the email address. 

For example, abc@example.com appears as prvs=tag=abc@example.com. 

Note

Note
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Because the string modifies the email address, the message header appears to have 2 
different addresses, causing the application to think that the message is a spam. This 
results in Websense Email Security blocking the email, despite adding the address to 
the Always Allow list in Personal Email Manager. 

To rectify this issue, Websense Email Security now recognizes email addresses that 
use the prvs tag. When an email has BATV turned on, it checks to see if the address 
with prvs tag is added to the whitelist or blacklist, and either allows or blocks the 
email appropriately.

Double scanning of files

A new feature is added that gives you the option to scan both the document and its 
content. By default, Websense Email Security scans only the text content of a 
document. You can now choose to also scan for the file type. 

With this option turned on, when Websense Email Security receives an email with an 
attached document, it first scans the file to determine the file type, then parses the 
document to text and scans the text content within the document.

To enable double scanning, in Rules Administrator, select Tools > Options > 
Dictionary Scanner and then select the Scan the documents whether decomposed 
or not check box. 

Detection of embedded .swf files in Microsoft Excel 
documents

Websense Email Security v7.3 can detect .swf Flash files that are embedded as a 
common object in Microsoft Excel documents. Flash files that are directly embedded 
as flash objects using a third-party add-on are not detected. 

Password-protected file detection supports new file types

Microsoft Office version 2007 or later and PDF files are now supported when 
detecting password-protected files in incoming and outgoing messages.

Enhanced TLS logging 

TLS (Transport Layer Security) is a protocol that ensures data transmitted over the 
network is secure and encrypted. Every message that is sent or received has a 
corresponding logging detail attached. The information contained in TLS is useful for 
identifying the source, content, and time stamp of a message. 
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In this release, detailed TLS log information is included to the Received section of the 
message header. This makes tracking and visualizing company policy compliance 
within a large organization easier.

TLS log information is also included in the database to show if there is a TLS 
connection.

Open Websense Email Message Administrator (Start > All Programs > Websense 
Email Security > Message Administrator). In the Logs panel, click Receive Log or 
Send Log to view the TLS information in the database.

Ability to import and export address lists as text files

Organizations with a large user database can benefit from the new import and export 
function. This function lets you import or export current address lists or domains as 
text files, making it easier to edit bulk data.

When importing address lists as text files:

 You can only specify one address per line.

 You can include up to 1024 characters per line.

 The file must be less than 8MB.

 The text file must be either Unicode or ANSI format.

When exporting address lists, the text file is exported in Unicode format.
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To import or export address lists as text files:

1. In Rules Administrator, create a new rule.

a. Select Rule > New Rule.

b. Ensure the Enabled check box is selected.

c. Type in a name and description for the new rule, and then click OK.

2. Select the new rule and then select the Who tab.

3. Choose whether you want to add recipients (To Users and Groups) or add 
senders (From Users and Groups), and then drag it to the right hand panel. 

4. Select a method to add users and then click Import or Export, depending on 
your requirements.

Delete messages by server name

A new functionality is added that lets you select a server name and delete the related 
messages in the database. This feature is useful for permanently deleting message log 
records in the database which previously could not be deleted in Message 
Administrator. For example, if you have multiple Websense Email Security servers in 
a network and a server is removed from the network, you will use this function to 
remove the log entries associated with the removed Websense Email Security server.

To access this option, open the Websense Database Wizard (Start > Websense Email 
Security > Database Tools > Log Database Management), select the Delete log 
records by server name option, and then follow the wizard instructions.

Directory Server integration with Account Management

Managing users in Websense Email Security Account Management  is now easier due 
to the integration of Administrator User with Directory Server. Previously, users had 
to be configured individually. With Directory Server integration, you can manage 
multiple users more efficiently:

 Import or export user filters as text files.

 Edit user permission level.

 Add or delete users and administrators.

When creating an import text file, each item in the list must follow this format:

 LDAP profile name@@@search query

Where:

 LDAP profile name is the name of the server defined in the Directory Harvest 
Detection.

 Search query is a valid Directory Server lookup query.
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 @@@ is a delimiter used to separate each field of data.

The import file must be less than 8MB, and the text file must be either Unicode or 
ANSI format.

Example of an import file:

10.227.2.105@@@(mail=user1*)

10.227.2.107@@@cn=user2*

To manage user accounts: 

1. Open the Monitor and then select File > Server Configuration.

2. In the left panel, navigate to the Administration service, and then select 
Accounts.

3. Click Directory Server to manage users from the Directory Server. You can  
add, remove, remove all, import or export user search filters.
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 Environmental support
Topic 40002 / Updated: 10-Nov-2010

Applies To:

Servers and clients

 Windows Server 2003 R2 

 Windows Server 2003 R2 x64

 Windows Server 2003 

 Windows Server 2003 x64

 Windows Server 2008

 Windows Server 2008 x64 

 Windows Server 2008 R2 x64

 Windows Small Business Server 2008

Clients only

 Windows XP

 Windows Vista

 Windows 7

Database servers

 SQL Server 2005 

 SQL Server 2005 x64

 SQL Server 2005 Express

 SQL Server 2008 

 SQL Server 2008 x64

 SQL Server 2008 Express 

Virtual server

 VMWare ESX / ESXi 4.0 

Web browsers

 Microsoft Internet Explorer version 7.0 or later

 Mozilla Firefox version 3.0 or later

Websense Email Security 7.3
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Windows Server 2000 is no longer supported.

Disk space recommendations 

For the Websense Email server machine:

 4 GB random access memory (RAM) (2 GB minimum)

 20 GB disk space (15 GB minimum)

If you are running Websense Email Security on the same server as Personal Email 
Manager, then Websense recommends the following minimum system requirements:

Component Requirement

Operation tips
Topic 40003 / Updated: 10-Nov-2010

Applies To:

Allow anonymous users to connect to Microsoft 
Exchange 2010

Due to higher security in Microsoft Exchange 2010, by default it does not allow 
anonymous users to connect to the server. You can change this default setting by 
modifying the Server Configuration settings.

Note

Processor Intel Pentium IV processor 3 GHz or higher

Memory 2 GB RAM minimum, 4 GB recommended

Disk Space 15.5 GB Minimum Disk Space, 21 GB recommended

Display Super VGA (800 x 600) or higher resolution video adaptor and 
monitor

Networking TCP/IP installed and configured with an Internet connection

Email Email system with SMTP gateway or MTA installed

Email security 
software

Websense Email Security v7.1 or later

Websense Email Security 7.3
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1. Open Microsoft Exchange 2010 Management Console.

a. Ensure you are logged in with Administrative privileges.

b. Select Start > All Programs > Microsoft Exchange Server 2010.

c. Select Exchange Management Console from the list of utility programs.

2. Under Microsoft Exchange, select Server Configuration to expand the sub 
menu items.

3. Select Hub Transport.

4. On the Receive Connectors tab, right-click Default MAIL and then select 
Properties.

5. Select the Anonymous users check box and then click OK.

Enable HTML in footers and headers

To enable HTML in footers and headers, ensure the object begins with a <html> tag 
otherwise the HTML cannot be translated. 

Example:

<html>Hello, <b>Websense</b>!</html>

Limit the size of messages processed by Rules Service

Websense Email Security Rules Service requires more memory to process large 
messages. You can set a limit in Rules Service to restrict large messages from being 
scanned against the rules to increase overall performance on the server. If a message 
exceeds the size specified, then Rules Service skips the message. 

1. Select Start > Run, and then type “regedit” to open the Registry Editor.

2. Select HKEY_LOCAL_MACHINE\SOFTWARE\SurfControl 
plc\SuperScout Email Filter.

3. Add a value to the registry key.

a. Select the new registry key and then select Edit > New > DWORD [or 
DWORD (32-bit) Value for 64-bit Windows].

b. Type “MaxMessageSizeForRuleService” and then press Enter.

c. Right-click the new registry key and then select Modify.

d. For Value data, specify a value (in MB) to restrict the message size 
processed by Rules Service.

Note

You may specify any value in the registry key. The size is 
determined by your environment and system. The larger 
the value, the larger the message size limit.
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Install Websense Email Security using an SQL Server 
named instance or non-default port

You can install Websense Email Security using an SQL Server with a named instance 
or with a non-standard SQL port.

To install Websense Email Security on an SQL Server named instance:

1. Ensure the SQL Server Browser service is running.

2. Run the Websense Email Security installation setup. 

3. On the Connect to SQL server page, assign a named instance server. The 
following methods are available:

 Select a named instance server from the Select the SQL server instance 
where Websense Email Security databases will be installed drop-down list.

 Add a named instance to the connection string. In the Select the SQL server 
instance where Websense Email Security databases will be installed field, 
type the instance name. The format is IP\instance_name. For example, 
10.100.10.88\MYINSTANCE.

4. Complete the installation wizard.

Fixed issues
Topic 40004 / Updated: 10-Nov-2010

Applies To:

The issues described in this section have been corrected in Websense Email Security 
v7.3.

 A problem that caused Rules Service to crash when processing an email with an 
attached Microsoft Word document that contains an embedded Excel object has 
been corrected

 Rules Service is capable of handling errors produced when ContentAccess fails to 
decompose a message received.

 The Dashboard integration with the SSL Directory Server now display the correct 
connection status.

Known issues
Topic 40005 / Updated: 10-Nov-2010

Applies To:
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The issues described in this section are known issues in Websense Email Security 
v7.3.

ODBC doesn't check the username and password when it connects to the 
database in NT authentication mode

Websense Email Security uses ODBC (Open Database Connectivity) to access the 
database, and in order to get a connection, it needs to authenticate. There are 2 
authentication modes: NT authentication and SQL authentication. 

By design, ODBC includes a username and password for SQL authentication, but not 
for NT authentication. When NT authentication is used to connect to the database, the 
ODBC does not check for a username and password. This means that non-existing 
users, or the wrong password are accepted.

There is currently no workaround for this issue.

Documentation notes and corrections

In the Websense Email Security Administrator Help document on page 43, there is a 
note in a table that reads: 

If selected, this overrides the Enable STARTTLS option in the ESMTP 
Commands dialog box. See ESMTP commands, page 38. 

This is incorrect and should be ignored.

Installation
Topic 40006 / Updated: 10-Nov-2010

Applies To:

To install a new installation of Websense Email Security:

1. Download the Websense Email Secuirty installation package from 
www.MyWebsense.com.

2. Double click the file to unzip it and launch the installer.

3. Follow the instructions in the Websense Email Security Installation Guide.

Upgrades
Topic 40007 / Updated: 10-Nov-2010

Applies To:

Websense Email Security v7.3 can be installed as an upgrade to versions 7.1 and 7.2.
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If you are running Websense Email Security v7.0 or earlier, you must first upgrade to 
version 7.1 or 7.2, and then upgrade to version 7.3.

If you have a supported version of Websense Email Security installed, then follow 
these instructions to upgrade to the latest version.

Upgrade is supported for the Server module only. The 
Client module is not supported. If you’d like to get the 
latest version for the Client module, first uninstall the 
existing version of Client applications, and then install the 
latest Websense Email Security product.

1. Download the Websense Email Security installation package from 
www.MyWebsense.com.

2. Follow the instructions in the Websense Email Security Installation Guide.

Migrations
Topic 40008 / Updated: 10-Nov-2010

Applies To:

Migrate data tool for SQL 2000

A new tool in Websense Email Security v7.3 lets you transfer data from SQL Server 
2000 to versions SQL Server 2005 or SQL Server 2008. Migration of data is much 
faster and more efficient.

1. Open the Database Data Migration Tool.

a. Navigate to the \Database folder in the directory where you installed 
Websense Email Security (typically C:\Program Files [or Program Files 
(x86) for 64-bit Windows]\Websense Email Security\Database).

b. Double click the file DBDataMigrationTool.exe.

Note
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2. Specify the server details for the source and destination data.

 Select the data source of migration panel: The server details which data is 
migrated from.

 Select the data destination of migration panel: The server details which 
data is migrated to.

 Server: You can type in an IP address, a server name and port, or an instance 
name.

 Authentication mode:

• Windows authentication does not require a username and password.
• SQL Server authentication requires a username and password. Ensure 

you have administrative privileges to use SQL Server authentication.

 Database: Select the database from which to migrate from (source), and 
migrate to (destination).

The following limitations apply to the database:

• The source and destination must be from the same database.

If the source database is from STEMLog, then the destination database 
must also be from STEMLog. There are currently 4 databases in Websense 
Email Security: STEMConfig, STEMDashboard, STEMFriendlyName, 
and STEMLog.

• The destination database must be a valid Websense Email Security 
database with proper database objects (for example, tables, views, and 
functions).

• The Database Data Migration Tool must be the only connection to the 
source and destination database. Disconnect other connections from the 
database before commencing the migration. 

3. Click Start to begin the migration process. 

4. Click OK when asked to confirm the migration.

5. When the migration completes, click Exit to finish.
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